Videos not working?

  • Visitor
  • Visitor
    Public
7 years 7 months ago - 7 years 7 months ago #252196 by
Replied by on topic Videos not working?
I use Chrome and I hate other browsers enough that I won't check in another. :lol:

Yeah, I'm getting the black boxes too.
Last edit: 7 years 7 months ago by .

Please Log in to join the conversation.

More
7 years 7 months ago #252212 by Edan
Replied by Edan on topic Videos not working?
It sounds like a Chrome issue. From a bit of a google it seems like this happens quite a lot.

Chrome's suggestions (though I suspect none of these will help): https://support.google.com/chrome/answer/6138475?hl=en&ref_topic=3421642&vid=1-635768104343310722-2642838301

I saw a suggestion somewhere that said that videos play when in incognito mode, worth a try to see if it works?

It won't let me have a blank signature ...

Please Log in to join the conversation.

  • Visitor
  • Visitor
    Public
7 years 7 months ago #253820 by
Replied by on topic Videos not working?
https://developers.google.com/youtube/flash_api_reference

According to the link above, Ren was right. It's not a browser issue. As I understand it, basically YouTube stopped supporting the type of embedding we use on the forums.

Please Log in to join the conversation.

More
7 years 7 months ago #253823 by MadHatter
Replied by MadHatter on topic Videos not working?

Jamie Stick wrote: https://developers.google.com/youtube/flash_api_reference

According to the link above, Ren was right. It's not a browser issue. As I understand it, basically YouTube stopped supporting the type of embedding we use on the forums.


Thanks for the update. However it all seems to be working again. So I have no idea. I am just glad its working lol.

Knight of the Order
Training Master: Jestor
Apprentices: Lama Su, Leah
Just a pop culture Jedi doing what I can

Please Log in to join the conversation.

More
7 years 7 months ago #253847 by Wescli Wardest
Replied by Wescli Wardest on topic Videos not working?
I don't know if it's just me, but I have found that when a video doesn't want to post the way I think it should if I right click on the video itself and copy the URL from there it tends to be quite successful.

I know that doesn’t help anyone on a phone. And I have NO idea why it would make a difference. But it has resolved the issue for me several times before.

Monastic Order of Knights
The following user(s) said Thank You: Br. John

Please Log in to join the conversation.

  • RyuJin
  • Offline
  • Master
  • Master
    Registered
  • The Path of Ignorance is Paved with Fear
More
7 years 7 months ago #253884 by RyuJin
Replied by RyuJin on topic Videos not working?
On a phone just press and hold until the menu pops up and select "copy url at current time", then paste it in the post....that's what I usually do

Warning: Spoiler!

Quotes:
Warning: Spoiler!

J.L.Lawson,Master Knight, M.div, Eastern Studies S.I.G. Advisor (Formerly Known as the Buddhist Rite)
Former Masters: GM Kana Seiko Haruki , Br.John
Current Apprentices: Baru
Former Apprentices:Adhara(knight), Zenchi (knight)
The following user(s) said Thank You: Wescli Wardest

Please Log in to join the conversation.

  • ren
  • Offline
  • Member
  • Member
    Registered
  • Not anywhere near the back of the bus
More
7 years 7 months ago #256373 by ren
Replied by ren on topic Videos not working?
youtube wants to use iframes, which with our current setup is a problem, as allowing our users to submit iframes which are then displayed by totjo means they can inject any code they like into our forum, loaded from an external source we do not control... iframes could be useful for genuine folk here, but even more so to whatever malicious person passes by. While there could be a workaround which would block all iframes except youtube's, it isn't worth doing at this time on the current version of the totjo website.

I'm not sure why youtube decided to use iframes, this is a pain.


Attachment h830a0bb.PNG not found


Convictions are more dangerous foes of truth than lies.
Attachments:
The following user(s) said Thank You: Proteus

Please Log in to join the conversation.

  • Visitor
  • Visitor
    Public
7 years 7 months ago #256377 by
Replied by on topic Videos not working?
My company's flagship product just signed an agreement to display as embedded in an iframe for a parent site... guess who's job it is to test the damn thing.

Please Log in to join the conversation.

More
7 years 7 months ago - 7 years 7 months ago #256411 by Edan
Replied by Edan on topic Videos not working?

ren wrote: youtube wants to use iframes, which with our current setup is a problem, as allowing our users to submit iframes which are then displayed by totjo means they can inject any code they like into our forum, loaded from an external source we do not control... iframes could be useful for genuine folk here, but even more so to whatever malicious person passes by. While there could be a workaround which would block all iframes except youtube's, it isn't worth doing at this time on the current version of the totjo website.

I'm not sure why youtube decided to use iframes, this is a pain.


So if this is the route they go, what does that mean for us and videos? No go?

It won't let me have a blank signature ...
Last edit: 7 years 7 months ago by Edan.

Please Log in to join the conversation.

  • ren
  • Offline
  • Member
  • Member
    Registered
  • Not anywhere near the back of the bus
More
7 years 7 months ago #256546 by ren
Replied by ren on topic Videos not working?

Edan wrote:

ren wrote: youtube wants to use iframes, which with our current setup is a problem, as allowing our users to submit iframes which are then displayed by totjo means they can inject any code they like into our forum, loaded from an external source we do not control... iframes could be useful for genuine folk here, but even more so to whatever malicious person passes by. While there could be a workaround which would block all iframes except youtube's, it isn't worth doing at this time on the current version of the totjo website.

I'm not sure why youtube decided to use iframes, this is a pain.


So if this is the route they go, what does that mean for us and videos? No go?


Use hacks described in this thread, and post videos as url ( use the forums url or code tags to avoid the auto-transform). Ive had to repair youtube embedding on this version of the site already, next time will be after the yet to be planned upgrade.

Mithers.

Convictions are more dangerous foes of truth than lies.
The following user(s) said Thank You: Jestor

Please Log in to join the conversation.

Moderators: ZerokevlarVerheilenChaotishRabeRiniTavi